Table of Contents

Namespace CryptoHives.Foundation.Security.Cryptography.Cipher

Classes

Aes128

AES-128 symmetric cipher implementation.

Aes192

AES-192 symmetric cipher implementation.

Aes256

AES-256 symmetric cipher implementation.

AesCcm

AES-CCM (Counter with CBC-MAC) authenticated encryption implementation.

AesCcm128

AES-128-CCM authenticated encryption.

AesCcm192

AES-192-CCM authenticated encryption.

AesCcm256

AES-256-CCM authenticated encryption.

AesGcm

AES-GCM (Galois/Counter Mode) authenticated encryption implementation.

AesGcm128

AES-128-GCM authenticated encryption.

AesGcm192

AES-192-GCM authenticated encryption.

AesGcm256

AES-256-GCM authenticated encryption.

AesGcmSiv

AES-GCM-SIV (RFC 8452) nonce-misuse-resistant authenticated encryption.

AesGcmSiv128

AEAD_AES_128_GCM_SIV nonce-misuse-resistant authenticated encryption (RFC 8452).

AesGcmSiv256

AEAD_AES_256_GCM_SIV nonce-misuse-resistant authenticated encryption (RFC 8452).

AesKeyWrapPad

AES Key Wrap with Padding as specified in RFC 5649 (and AES Key Wrap per RFC 3394).

Aria128

ARIA-128 symmetric cipher implementation.

Aria192

ARIA-192 symmetric cipher implementation.

Aria256

ARIA-256 symmetric cipher implementation.

AriaCcm

ARIA-CCM authenticated encryption (ARIA per RFC 5794, CCM per RFC 3610).

AriaGcm

ARIA-GCM authenticated encryption (ARIA per RFC 5794; used in TLS by RFC 6209).

AsconAead128

Ascon-AEAD128 authenticated encryption as specified in NIST SP 800-232.

Camellia128

Camellia-128 symmetric cipher implementation.

Camellia192

Camellia-192 symmetric cipher implementation.

Camellia256

Camellia-256 symmetric cipher implementation.

CamelliaCcm

Camellia-CCM authenticated encryption (Camellia per RFC 3713; used in IPsec by RFC 5528).

CamelliaGcm

Camellia-GCM authenticated encryption (Camellia per RFC 3713; used in TLS by RFC 6367).

CcmCipher

CCM (RFC 3610, NIST SP 800-38C) authenticated encryption over a 128-bit block cipher other than AES.

ChaCha20

ChaCha20 stream cipher implementation as specified in RFC 8439.

ChaCha20Poly1305

ChaCha20-Poly1305 authenticated encryption as specified in RFC 8439.

GcmCipher

GCM (NIST SP 800-38D) authenticated encryption over a 128-bit block cipher other than AES.

Kalyna128

Kalyna-128 symmetric cipher implementation (DSTU 7624:2014).

Kalyna256

Kalyna-256 symmetric cipher implementation (DSTU 7624:2014) with 128-bit block.

Kalyna512

Kalyna-512 symmetric cipher implementation (DSTU 7624:2014).

Kuznyechik

Kuznyechik (GOST R 34.12-2015) symmetric cipher implementation.

KuznyechikGcm

Kuznyechik-GCM authenticated encryption (GOST R 34.12-2015).

KuznyechikMgm

Kuznyechik-MGM authenticated encryption: the Multilinear Galois Mode of RFC 9058 (R 1323565.1.026-2019) over GOST R 34.12-2015 Kuznyechik, as used by GOST TLS 1.3 (RFC 9367).

Magma

Magma (GOST R 34.12-2015, RFC 8891) symmetric cipher implementation.

MagmaMgm

Magma-MGM authenticated encryption: the Multilinear Galois Mode of RFC 9058 (R 1323565.1.026-2019) over GOST R 34.12-2015 Magma, as used by GOST TLS 1.3 (RFC 9367).

Seed

SEED symmetric cipher implementation (KISA, RFC 4269).

SeedGcm

SEED-GCM authenticated encryption (RFC 4269).

Sm4

SM4 symmetric cipher implementation (GB/T 32907-2016).

Sm4Ccm

SM4-CCM authenticated encryption (SM4 per GB/T 32907-2016; the TLS 1.3 suite TLS_SM4_CCM_SM3 of RFC 8998).

Sm4Gcm

SM4-GCM authenticated encryption (SM4 per GB/T 32907-2016; the TLS 1.3 suite TLS_SM4_GCM_SM3 of RFC 8998).

SymmetricCipher

Base class for CryptoHives symmetric cipher implementations.

XChaCha20Poly1305

XChaCha20-Poly1305 authenticated encryption with extended nonce.

Interfaces

IAeadCipher

Defines an Authenticated Encryption with Associated Data (AEAD) cipher.

ICipherTransform

Defines a cryptographic transform for symmetric cipher operations.

Enums

CipherMode

Specifies the block cipher mode of operation.

PaddingMode

Specifies the padding mode for block cipher operations.